Uus PHP 8 versioon nüüd Veebimajutuses saadaval

PHP on veebiarenduses kõige populaarsem programmeerimiskeel, millel põhineb nii WordPress, Laravel, Drupal, Magento kui ka paljud teised platvormid või raamistikud. Enamus meie pea 20 000 kliendist kasutab oma veebirakenduse jooksutamiseks PHP programmeerimiskeelt. Äsja nägi ilmavalgust ka PHP uusim, 8. versioon, kus taas tehtud suur samm edasi parema koodibaasiga veebirakenduste suunas, lihtsustades arendajate tööd.

PHP on viimastel aastatel palju edasi arenenud ning viimati tulid suuremad muutused välja PHP 7. versiooniga. Selle uuenduse tulemusel muutus veebirakenduste kood arendajatele palju selgemaks, veebirakendused said kiiremaks, kuid samas muutus vanematelt PHP versioonidelt üleminek raskemaks.

Vana PHP versioon vajab arendaja parandusi

Vanemad, PHP 5.x versioonidele loodud veebilehed on paraku aga endiselt sellises seisus, et nende üleviimine mõnele uuemale PHP versioonile on raskendatud. Veebileht võib vajada veebiarendaja sekkumist, parandused võivad endas sisaldada ka mahukaid muudatusi koodis. Sellega puutume me kliente aidates igapäevaselt kokku.

Praegu muutuvad veebitehnoloogiad aina kiiremini ning juba nägi ka ilmavalgust uusim PHP 8. versioon, kus on jälle tehtud suur samm edasi arendajate töö lihtsustamiseks. Selle uuenduse tehnilisest poolest saab lugeda meie blogi “Eksperdile” kategooriast.

PHP 8 on kõikidele meie klientidele nüüd iseteeninduses valitav “Veebiserver -> Seaded” alt. WordPress sai PHP 8 toe planeeritult 8. detsembril 2020, seega soovitame enne PHP 8 peale üleminekut WordPress ära uuendada. Veebiarendaja olemasolul on mõistlik ka tema üleminekuprotsessi kaasata.

Uut PHP-d saab kohe proovida

Uue versiooni toimimist on võimalik lihtsalt proovida ning kui tekib probleeme, siis saab iseteeninduses vanale PHP versioonile ajutiselt tagasi lülituda.

Piltidega juhend selle proovimiseks on siin: veebimajutus.ee/klienditugi/juhendid/kodulehe-testimine-uuema-php-versiooniga

Eraldi soovime välja tuua ka selle, et praeguseks on juba aegunud ka PHP 7.0, 7.1 ja 7.2 versioonid (rääkimata PHP 5.6 versioonist), mis tähendab, et neid enam ei toetata ning turvaparandusi ei tehta. Ka meie ei saa veebimajutuse tavapakettides vanemaid PHP versioone enam pikalt toetada. Soovitame kindlasti pöörata sellele tähelepanu, kui meilt PHP aegunud versiooni kohta teavitus tuleb.

PHP 5.2, PHP 5.3, PHP 5.4, PHP 5.5 versioone kasutanud kliendid on kõik kenasti ennast ära uuendanud - meie platvormil enam ühtegi klienti nii vanadel versioonidel ei ole. PHP 5.6 tugi kaob meie tavapakettidest ära 2021.a. jooksul, täpsema kuupäeva ja tingimuste osas anname klientidele otse teada järgmise aasta alguses.

Jaga