Minu koduleht kasutab aegunud PHP versiooni. Mis nüüd saab?

Mis tähendab vananenud PHP versioon?

Tarkvaraarenduses kasutatakse erinevate väljalasete märgistamiseks versioone. Tarkvarade välja laskmisel määratakse tihtipeale ära aeg, kui kaua tarkvaratootja seda tarkvara toetab (pakub turvauuendusi ning kasutajatuge). Kui see tähtaeg möödub, siis muutub tarkvara aegunuks ehk seda enam ei toetata ega uuendata turvaparandustega. See tähendab seda, et aegunud tarkvara võib olla ka turvalisuse seisukohalt ohtlik, kuid see ei ole reegel. Aegunud PHP versioonist olulisem on see, et kui teie kodulehekülg kasutab aegunud PHP versiooni, siis on see väga suure tõenäosusega ka ise aegunud, mis võib aga märksa suurem probleem olla.

Mis siis juhtub kui mu kodulehekülg kasutab aegunud tarkvara?

Me ei saa väita, et iga aegunud tarkvaraga tehtud kodulehekülg oleks turvarisk, kuid enamlevinud platvormide nagu Wordpress või Joomla puhul on see väga tõenäoline - eriti kui kasutusel on lisafunktsionaalsust pakkuvad pluginad. Kodulehe tarkvara värskena hoidmine on turvalisuse seisukohalt oluline, sest turvaaukudega veebilehele saab halbade eesmärkidega inimene lihtsa vaevaga ligi ning kodulehel andmeid muutes vabalt teie mainet rikkuda.

Kui kaua toimib PHP 5.6 versioon?

Hetkel on meil plaanis seda pakkuda 2019.a. lõpuni, seega tasub selle versiooniga oma kodulehe tööd kindlasti proovida, lükates nii tekkinud probleemi veidi edasi. Pikas perspektiivis see aga lahendus ei ole - kodulehe tarkvara on igal juhul vaja uuendada või asendada.

Miks te ise ei uuenda minu teenuse PHP versiooni 5.6 peale, kui selle tugi veel veidi aega kestab?

Me leiame, et meil ei ole õigust kliendile kuuluva tarkvaraga omavoliliselt katseid teha. Juhul kui PHP versiooni muutmine uuema peale katkestab kodulehe töö, on teil ikkagi vaja abi kodulehe arendajalt ning meie seda rolli täita ei saa.

Minu koduleht on tehtud nii vana tarkvara peale, et seda ei ole enam mõistlik uuendada. Mida teha?

Kui kasutate tarkvara, mida ammu ei arendata (nt. Saurus CMS), siis on mõistlik uue kodulehe tegemisele mõelda.

Kui kodulehe eesmärk on olla teile või teie teenustele vaid visiitkaart, siis võite selle vabalt ka ise teha, tellides meie "Tee-ise-veeb" paketi, mis võimaldab lihtsate vahenditega endale uue veebilehe luua.

Kui soovite aga põhjalikumat lahendust ning ise mitte sellele ülearu aega raisata - keskendumaks oma ärile - siis saate asjatundlikku abi meie partneritelt.

Kuidas ma tean, kas mu koduleht töötab uuema PHP versiooniga?

Kõige lihtsam viis on lihtsalt proovida uuema versiooniga ning kui koduleht lakkab töötamast - minna tagasi vana versiooni peale ning lahendust edasi otsida. Juhendi PHP versiooni muutmiseks leiad siit. Juhul kui sul on probleeme proovimisel või sa ei julge ise proovida, võid alati meie klienditoe poole pöörduda, kuid pead arvestama sellega, et meie ei saa kodulehe koodi ühilduvust parandada.

Juhul kui soovid, et sinu probleemi aitaks lahendada pädev spetsialist, siis soovitame konsulteerida oma kodulehe autoriga või leida selleks abi meie partneritelt.

Mulle kuvatakse aegunud PHP versiooni teadet, aga mu veebileht on "Tee-ise-veeb" lahenduse peal. Kas ma pean muretsema?

Kuvame teadet, sest sul on meie serverisse loodud FTP konto - mis võib viidata sellele, et sinu kodulehe arendaja on näiteks mingit lisafunktsionaalsust meie serverisse paigutanud - seega tuleb see igaks juhuks üle vaadata. Juhul kui sul ei õnnestu kodulehe arendajalt abi paluda, siis võid ka meie klienditoega konsulteerida - püüame hinnata, kas sul on põhjust muretsemiseks. Me oleme siin selleks, et sind aidata niipalju, kui meile jõukohane.

Kuidas ma lahendan selle probleemi nii, et ma enam ei peaks sellega iialgi tegelema?

Säärast lahendust on võimalik leida vaid siis kui te kasutate kodulehe platvormi, mille kõhupool on kommertslikus mõttes suletud ning teie saate vaid oma kodulehe välimust ja sisu muuta. Üheks selliseks tooteks on näiteks meie "Tee-ise-veeb" teenus.

Alternatiiviks on tellida kodulehekülg ettevõttelt, kes pakub seda koos haldusteenusega või sootuks täislahendusena. Kui olete otsimas endale selleks partnerit, soovitame kindlasti küsida, kas nad pakuvad ka püsivat haldusteenust - sellisel juhul vastutavad nemad kodulehe tarkvara ajakohasuse eest ning teie saate muretult oma ärile keskenduda.

Kas aegunud PHP versioon mõjutab kuidagi ka minu e-posti tööd?

Ei, veebiserveriga seonduvad asjad ei ole e-postiga kuidagi seotud.

Ei leidnud, mida otsisid? Küsi meilt, me aitame!

Helista numbril 683 5188 või kirjuta abi@veebimajutus.ee

Või saada oma küsimus siin, võtame sinuga ühendust nii pea, kui võimalik.

Vale vastus
Cart